Exim: maximum message size

Problem Description

I’d like to increase the maximum size for outgoing emails. Can I do that with sympl? If not, how/where should I edit the exim config?

Environment

  • Sympl Version: 10
  • Sympl Testing Version? No
  • Debian Version: Buster
  • Hardware Type? Virtual
  • Hosted On? Bitfolk

Interested in this, so I did a little bit of research.
First, I’m pretty sure Sympl does not have a way to set a message size limit.
It’s 50MB by default in Exim4.
You can set message_size_limit in exim4.
The exim4 configuration for sympl is in
/etc/exim4/sympl.d
and after editing any file in that directory tree, you rebuild the configuration by going back to
/etc/exim4
and running make.

Disclaimer: From here on, I 'm getting slightly out of my depth, but I would guess that the sensible file to edit is
/etc/exim4/sympl.d/00-main/80-resource-control
and it may be as simple as adding a line
message_size_limit = ###
where ### is your new value.
Reading around other advice on the web, you may also need to raise message size limits for spam filters and the like, or messages over their limits will cause them to raise errors.
Personally, I’d try this first on a machine where failure wouldn’t matter, before editing a live server!

@Anahata covers the process of updating the config, but you’re going to start have problems sending mail over 20MB to most places, as sizes for single messages tend to be limited by the receiving host, partially to prevent abuse (filling up someones mailbox), and partially for historic reasons (20MB used to be a lot for a single TCP stream on a slow link).

Typically any larger stuff should probably be sent via a normal file transfer service, or you can set up Sympl with some FTP space, and have someone upload/download the files that way.

Thanks. I probably won’t be able to try it until Monday at the earliest. I’ll try to remember to report back.

I know that what I’m asking for would normally be ridiculous and pointless. Usually when I need to send a large file I use a service like WeTransfer or a Nextcloud share.

But in this case, I have a very specific need to email one very large file.

I tried adding a message_size_limit value to 00-main/80-resource-control and 00-main/60-general-options but neither of them appeared to work.

I’m starting to think that it’s not worth the trouble :frowning:

You’ll need to add the entries to the files, then run sudo make from /etc/exim4 to build the new config, then you can restart the service to have the change take effect.

That was it, thank you :slight_smile: