Email files served by Dovecot

I’ve got a Symbiosis server which I’m looking to move to Sympl at some point, but I need to fix a couple of issues first. One is that some emails on disk don’t show in IMAP clients, for example:

  • 1575648716.M193166P1443.mail.example.org,S=10113,W=10398:2,Sa: Does show.
  • 0000652880-Subject of email.eml:2,S: Does not show.

I think the *.eml files have been imported from another piece of software simply by copied the files across, instead of using a tool like imapsync.

Does Dovecot as configured by Symbiosis/Sympl only pick up files which match a particular file glob? If not there are some other avenues I can explore, but I want to make sure I’m not missing something really obvious first. :slight_smile:

I’ve never had a problem copying IMAP file directories from one server to another (some have survived at least two moves) but they were always from other Dovecot-administered Maildir stores. In the examples above I’d be suspicious about the spaces, if “Subject of email” is literal.

As an experiment I’d try renaming changing spaces to underscore or similar, but I’m wandering out of my depth here…

I can’t see anything immediately in the Sympl configs, but looking at a normal Sympl mailbox, I can see files with the first longer filenames which seem to be fine, but I wouldn’t be that surprised if the Dovecot configuration doesn’t like the naming of the second example, as it looks like it’s expecting the files to be named something like <timestamp>.<ID>.<hostname>,<flags>.

After some poking, adding *.eml to existing files doesn’t change anything significant, so I’d be tempted to rename one of the non-visible ones to match the naming of the visible ones, at which point it’ll probably appear.

Using imapsync may be the best option in this case.

Thanks for the pointers, they give me a couple of things to try. The spaces in the email are literal so I might rename those first, and on close examination it looks like the imported files have slightly different permissions too.

Spaces in file names don’t seem to be a problem, Dovecot shows up *.eml files regardless. However, permissions and ownership do seem to be an issue. Are the correct permissions for email:

  • Owner: admin
  • Group: admin
  • Permissions: 0500 (aka owner rw, no other permissions)

Some of the files seem to be 0 bytes in size, but there’s nothing I can do about that.

Mine have owner sympl:sympl
permissions -rw-------

(isn’t the ‘admin’ user a symbiosis thing?)

Yes, this is a Symbiosis server that I’m trying to get into shape so it can be moved to Sympl.

One of the things Sympl does is reset permissions and ownership on the public, config, and mailboxes directories, so you shouldn’t see the permissions thing again once you migrate. :slight_smile: